
QXPRESS VERSION 7.0 FEATURE LIST

This document lists the main new features included in the QXpress version 
7.0 release. For every feature listed, there is also a description of the 
feature and step-by-step instructions explaining how to use the feature.

QUICKBOOKS INTEGRATION

1. QuickBooks 2007 compatibility

Versions: All

QXpress 7.0 has been configured to be compatible with the upcoming 
release of QuickBooks 2007.

2. Customer’s Sales Rep automatically set on new service

Versions: All

When a new service is scheduled, QXpress will look at the QuickBooks 
customer you are scheduling for to see if there is a Sales Rep assigned to 
them. If so, it will automatically assign that Sales Rep to the service in 
QXpress.

3. ‘Hide Job Items where Actual Quantity = 0’ checkbox

Versions: Gold, Platinum, Enterprise

A new checkbox has been added to the Inventory Adjustments screen. We 
received feedback from users saying that they only wanted to send 
inventory adjustments on services they were tracking actual quantities on, 
and as it stood they either could not use the Inventory Adjustments screen 
in QXpress, or were faced with tracking actual quantities used on every 
single job. The solution is to allow you to select to ignore inventory 
adjustments where no actual material usage was entered.
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To ignore inventory adjustments for job items that have 0 actual 
quantity:

1) Click Post To QuickBooks > Inventory Adjustments.

2) In the lower left-hand corner, put a check in the Hide Job Items where 
Actual Quantity =0 checkbox.

4. Integration with Item Groups

Versions: Gold, Platinum, Enterprise

QXpress is now compatible with QuickBooks Item Groups. An Item Group 
is a name given in QuickBooks to a collection of several service, inventory 
and non-inventory parts, in pre-set quantities. For example, if you were to 
install “Widget A”, you could make a “Widget A Installation Group” in 
QuickBooks, comprised of 2 labor hours of the service item “Widget Labor”, 
1 unit of the inventory part “Widget A” and 15 feet of the non-inventory part 
“Wire”.

This is a major feature for HVAC, Plumbing, Electrical Contracting, and 
Irrigation companies that deal with Flat Rate pricing models.

To schedule a new service using an Item Group:

1) In QuickBooks, in the Item List, create an Item Group, ensuring that at 
least one of the items of the Item Group is a service item.

2) In QXpress, click Schedule > New Service.

3) Choose the newly created Item Group.

4) In the Service screen, click on the Job Items tab. You will now see all the 
items have automatically been placed on the service. You will also see the 
first service item listed in the Item Group has been used as the parent 
Charge Description for this service.

To add the contents of an Item Group to an existing service:

1) In QuickBooks, in the Item List, create an Item Group.

2) In QXpress, edit any existing service.

3) Click on the Job Items tab.
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4) Click Add.

5) From the dropdown list in the Description column, choose the Item Group 
you created.

6) You will now see all the items have automatically been placed on the 
service.

Note: Existing QXpress users may have to do a full synchronization between QXpress and 
QuickBooks by (1) clicking the green QX Sync icon; and (2) then clicking Get new QB 
Data, in order to synchronize with existing Item Groups for the first time.

Note: While QXpress now recognizes Item Groups, there are two shortcomings: (1) 
QXpress uses all the items from the Item Group, but discards the actual Item Group 
name; and (2) QXpress ignores the ‘Print items in group’ checkbox.

5. Improved trouble reporting on QuickBooks integration

Versions: All

In an effort to help troubleshoot issues with the full QX Sync procedure, all 
common issues bring up a more informative, detailed message displaying 
suggested solutions to aid in correcting the problem.

QX Mobile

6. Template Designer template compatibility

Versions: All - requires the QX Mobile module

You are now able to use the majority of templates from Template Designer 
in QX Mobile, assuming if you have one of the specified printers (see 
www.qxpress.com/QXMobile for suitable printers).

There are two ways to use a template created in the Template Designer:

(A) For templates to be used by all crews that sync with the Template 
Designer:

1) Open the QX Mobile Server.
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2) Select the Advanced > Template Designer tab.

3) There will be 3 dropdown lists. Each will list either work orders/route lists, 
invoices or estimates. Select the templates you would like to use in QX 
Mobile. If you'd like to use the default templates on QX Mobile, leave the 
dropdown list blank.

4) Make sure your Pocket PC is in the cradle.

5) Click Synchronize.

6) Start QX Mobile.

7) Edit an occurrence of a service by selecting a service in My Calendar and 
clicking Schedule > Edit Occurrence.

8) Select Print from the dropdown list in the top right of the screen.

9) Select either Invoice, Work Order or Estimate from the dropdown list. The 
template selected in step 3 will be used.

(B) For templates to be used from a profile:

1) Open the QX Mobile Server.

2) Select the General tab.

3) Select the Select/Create Profile option.

4) Either select a current profile and click Edit or click Add, accordingly.

5) Select the Template Designer tab.

6) Select the templates you wish to use for work orders/route list, invoices 
and estimates for this QX Mobile user’s profile.

7) When all the information for the profile is created, click Finish.

8) Continue from Step 5 in the previous (A) section.

7. Create your own Custom Data Entry screen

Versions: All - requires the QX Mobile module

You can now create your own Custom Data Entry screen, which replaces 
the old Time / Material screen. This allows to collect and display the 
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information that is relevant to your company on one screen for your field 
staff! The Custom Data Entry screen can list Equipment, Job Items, Act. 
Service Times, Act. Material Usages, etc. You will also be able to drag and 
drop and resize controls. If you do not make any changes to the Custom 
Data Entry, then the old Time / Materials screen will be used.

To create your own Custom Data Entry screen:

1) Open the QX Mobile Server.

2) Select the General tab.

3) Select the Select/Create Profile option.

4) Either select a current profile and click Edit or click Add, accordingly.

5) Click the second tab. This is most likely called “Custom Data Entry”. (This 
name will be renamed by you in the next step).

6) Section 1: Page Layout. You will be allowed to resize the grid area to 
Portrait or Landscape. You can also name the tab. The name entered here 
will be the name of the Profile Wizard tab (instead of Custom Data Entry) 
and will appear in QX Mobile under Schedule.

7) Section 2: Tab Information. You can name each of the three tabs in this 
area. When you start to type, the tab which has focus will change name. 
Note the tabs will appear at the bottom of the screen in QX Mobile.

8) Section 3: Select Type of Control to Add. The are three grouping of 
controls. Standard, List and Special. Click the Type drop down to see all 
the different control options you have. For example if Standard Equipment 
List is selected, you will be able to add a control box that is associated with 
adding to the Equipment List. List Equipment List will allow a grid to be 
placed into the tab. Special controls allow you to add a Charge Description 
to the form. This will be explained in the next section.

9) Section 4: Control Properties. Here is where you can add a control to the 
grid depending on what was selected in Section 3. If Standard Equipment 
List was selected, then listed under the control drop down in section 4 will 
appear all the controls that can be added for the Equipment List. Select a 
control and click Add and you will see the control added to the tab. You 
can move and resize the control as you wish. To change the label name of 
the control, click on the control in the tab and then change the value in the 
Name text box in section 4. If a List *** is selected, then the first option in 
the control grid will be Add Grid. Make sure this is selected and click Add. 
You'll see the grid added to the tab. Then you can select the columns in 
the Control drop down. Once the desired column is selected, click Add. 
Special controls will have two options in the Control drop down. One will 
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be ChargeDescriptionDescription and the other EmployeeName. If you 
select ChargeDescriptionDescription, a drop down control will be added. 
Select the Charge Description to be associated with this control on the tab. 
To the left of the added drop down box you'll see a white area, this will be a 
checkbox to include or exclude this charge description when saving. To the 
right of the added drop down box there is another white area. This will be 
the quantity to add to the Charge Description when saving. If 
EmployeeName is added, then a combo box listing all employees will 
appear. Here is where you can assign a specific employee for the addition 
of the Charge Description.

10) When the controls are set up to your liking, click Finish.

8. Record payments received in the field

Versions: Gold, Platinum, Enterprise + requires the QX Mobile module

You are now able to take detailed payment information in the field for 
services that have the status On Route or Done.

To receive a payment, perform the following steps:

1) Open QX Mobile.

2) Select a service from My Calendar. Make sure the service is OnRoute or 
Done.

3) Click Schedule > Edit Occurrence.

4) In the top right there select Payment from the dropdown list. 

5) Enter desired payment information.

6) Click Save.

7) The next time you synchronize in QX Mobile Server, the payment will be 
entered into QXpress, and will appear in the Job Items tab for the service. 
When you create an invoice for the service in QXpress, the payment will 
be entered into QuickBooks.

9. Take photographs, such as before and after pictures

Versions: Gold, Platinum, Enterprise + requires the QX Mobile module + 
requires a Pocket PC with Windows Mobile 5.0 or higher with a camera.
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You are now able to take pictures in the field for services, that get inserted 
into contact manager events in QXpress.

To add a picture to a contact event, perform the following steps:

1) Open QX Mobile.

2) Click Customer > Customer List.

3) Select a customer.

4) Click Go to Customer.

5) In the top right dropdown list, select Contact Event.

6) Fill out the information for a new contact. You'll see a button called Take 
(you may have to scroll down).

7) Capture the picture as you would regularly. The screen should close by 
itself. If not, click OK in the top right.

8) The picture will be stored with this contact. Click Save to save the contact.

9) The next time a synchronization is complete, the picture taken will be 
transferred to the desktop and associated with the contact event.

10. Enter vendor bills & purchase orders in the field

Versions: Gold, Platinum, Enterprise + requires the QX Mobile module

You are now able to create Vendor Bills and P.O.s in QX Mobile. If you 
have QX Mobile Server properly set up, you may also synchronize 
remotely with your desktop and receive back the P.O. number assigned by 
QuickBooks while still in the field.

To create a vendor bill or purchase order perform the following:

1) Start QX Mobile on the Pocket PC.

2) Select a service that is OnRoute or Done.

3) Select Schedule > Edit Occurrence.

4) Select Act. Material Usage from the top right dropdown list.
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5) Click Create Bill/P.O. for materials purchased in field....

6) Select whether you are creating a Vendor Bill or P.O. Number.

7) Select the information in the controls listed.

8) Click Tools > Add Job Item to add Job Items to the Vendor Bill or P.O. 
Number.

9) Select the Charge Description you wish to add from the Charge 
Description List and fill out the desired information.

10) Click Add.

11) Repeat steps 9 and 10 for each Charge Description you wish to add. 
When complete, click Back.

12) You'll be back to the Create Vendor Bill/P.O Number screen.

13) Click Save Options > Save to save the Vendor Bill / P.O. Number.

14) If you are adding a P.O. Number, have wireless services active on your 
pocket pc, QuickBooks is open on your desktop and QX Mobile Server is 
set up properly to listen for incoming request, you will be able to retrieve 
the P.O. Number assigned by QuickBooks. To do this click Save Options > 
Save & Sync. You'll see the progress of the request in the top of the 
screen. If the service cannot be synchronized, the information will still be 
saved on your PDA and will be synchronized next time you synchronize 
with the desktop via the cradle.

11. Add Equipment to a Customer

Versions: Gold, Platinum, Enterprise + requires the QX Mobile module

You are now able to add a equipment to a specific customer in the field.

To add equipment to a specific customer perform the following steps:

1) Open QX Mobile on the Pocket PC.

2) Select Customer > Customer List.

3) Select the customer you wish to add an new equipment for.

4) Select Go to Customer.
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5) Select Equipment from the dropdown list in the top right corner.

6) Fill in the information for the new equipment.

7) Click Save.

8) Your new equipment for this customer will be listed in the bottom of the 
screen.

12. Send Email to Customer

Versions: Gold, Platinum, Enterprise + requires the QX Mobile module

You can now send an email to a customer if a service is listed in My 
Calendar. The process works along similar lines as calling a customer from 
QX Mobile.

To send an email to a customer:

1) Open QX Mobile on the Pocket PC.

2) Select a service from the My Calendar (if nothing appears make sure at 
least one service is listed in QXpress in My Calendar and then 
synchronize with QX Mobile Server).

3) Select Customer > Email XXX (where XXX is the customer’s email). If 
you don't see an email address, then you can enter an email address for 
the customer within QX Mobile. The next time you synchronize, the email 
address will be entered into QXpress and QuickBooks.

4) Enter the information to send the email.

To set default subject and body information when sending email:

1) Open QX Mobile on the Pocket PC.

2) Click Activities > Preferences.

3) Select Internet, in the top right corner.

4) Under Default Email Subject and Default Email Body, enter the desired 
information.

5) Click Save.
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SCHEDULING

13. Crew Vocabulary

Versions: All

You can now rename the “Crew” in QXpress to one of the following 
choices: “Crew”, “Room”, “Team”, “Tech” or “Truck”.

To change the Crew Vocabulary:

1) Click Edit > Preferences.

2) Click on the Routing & Scheduling tab.

3) Make a selection from the Crew Vocabulary dropdown list.

4) Click OK.

5) You will have to close and then re-open QXpress for all changes to take 
place.

14. Crew Number no longer used

Versions: All

In prior versions of QXpress, each Crew had a designated 3 letter Crew 
Number and a 30 character Crew Name. This has now been changed so 
that there is only the 30 character Crew Name shown in QXpress, and the 
Crew Number is no longer used.

All existing databases will be upgraded so the new Crew Name will be a 
combination of the old Crew Number plus the old Crew Name. You can 
rename your crews to remove the number if you prefer.

15. Blackouts for Crew Availability (Day / Week View)

Versions: All
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For those using the Day or Week View calendar, you can now block off 
certain days and times that a crew is not available, as well as give a reason 
for the lack of availability.

The blocked off time will appear as a blacked-out appointment area in the 
calendar.

To block off crew availability:

1) Click Lists > Crews.

2) Choose the crew you want to block availability for from the Crew Name 
dropdown list.

3) Click Block Availability.

4) Click Add.

5) Choose the From and To date range you wish to block.

6) Choose the times you wish to block.

7) Select which days of the week you wish to block.

8) Enter a reason for the lack of availability, such as ‘Vacation’, ‘doesn’t work 
Wednesdays’, etc.

9) Select any additional crews you wish to block availability for.

10) Click OK.

11) Click OK.

12) Click OK, to return to My Calendar.

To edit a blocked-off crew availability:

1) Double-click on the black area on the calendar representing the blocked-
off crew availability.

2) Make any edits as necessary.

3) Click OK.
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16. Customer Services List

Versions: All

A new screen has been added that lists all the services scheduled for all 
customers. This is designed to be especially useful for companies looking 
for a list of all outstanding estimates, or all ongoing projects.

To turn the Customer Services List feature on / off:

1) Click Edit > Preferences.

2) Click on the Routing & Scheduling tab.

3) Set your preference for the Enable Customer Services list checkbox.

To open the Customer Services List:

1) Click Lists > Customer Services List.

2) From the Show dropdown list, select the filter you want to place on this list. 
For example, if you wanted a list of all projects with an ‘Estimate’ status, 
select “Estimate: Project“.

17. More advanced defaults for recurring services

Versions: All

You can now set additional default values for recurring services, such as 
Max visits, Min days between visits, Basis, and Allow days.

To set advanced defaults for a Charge Description:

1) Click Lists > Charge Description List.

2) Click on the Charge Description you want to set advanced defaults for.

3) Click Advanced.

4) Click on the Advanced tab.

5) In the Advanced Options for Recurring Services frame, set the advanced 
properties you desire.
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6) Click OK. Any recurring service scheduled from this point forward for this 
Charge Description will now have your advanced default settings.

18. Unlimited ‘Job Kinds’

Versions: All

In prior versions of QXpress, you were limited to 3 Job Kinds. In addition to 
these original 3 Job Kinds, you can now add unlimited Job Kinds of your 
own.

To add / edit Job Kinds:

1) Click Lists > Charge Description List.

2) Click anywhere inside the Job Kinds column.

3) Choose “Edit” from the dropdown list in the Job Kinds column.

4) Click Add.

5) Type the name for your new Job Kind.

6) Double-click on the black color to set a new color for this Job Kind.

7) Click OK.

Note: Only the original 3 Job Kinds can be used for Zone based scheduling, and have the 
specialized tracking for Last Job Kind Date (found under the Routing & Invoicing tab 
in the Customer screen.

19. “Day: time on top” and “Week: time on top” views

Versions: All

In addition to List, Day, Week, Month and Cust views, there are two new 
views added. The “Day: time on top” and “Week: time on top” views are 
recommended for companies that have more than 5 crews, as they provide 
an easier way to see many crews in the calendar.
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To turn on the ‘Time On Top’ views:

1) Click Edit > Preferences.

2) Click on the Day View tab.

3) Place a check in the Show ‘Time On Top’ view options checkbox.

4) Click OK.

5) In My Calendar, you’ll the Day and Week views renamed to “Day: time on 
left” and “Week: time on left, respectively. You’ll also see the new “Day: 
time on top” and “Week: time on top” views available.

20. Service-level custom fields in List View

Versions: Gold, Platinum, Enterprise

In prior versions of QXpress, you could only see service-level custom fields 
in the Day or Week view. In QX7 you can now add these fields as columns 
to the List view of My Calendar.

To make service-level custom fields available in List view:

1) Click Edit > Preferences.

2) Click on the List View tab.

3) Place a check under the Show? column beside the custom field you want 
to have shown in My Calendar.

4) Click OK.

Note: Including custom fields at the service level can cause a decrease in speed / 
performance.

Note: The icons of the custom field dropdown lists will not show in List View.
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JOB COSTING

21. Vendor Bills & Purchase Orders

Versions: Gold, Platinum, Enterprise

In past versions of QXpress, it was assumed that materials were not 
bought for a specific service for a specific customer, rather that materials 
were taken from a large stockpile of inventory. This posed a problem for 
service companies that purchased materials in the field at the time of 
service, since double-entry had to be made, once for either the Vendor Bill 
or Purchase Order in QuickBooks, and then again in the Act Mat. Usage 
tab in QXpress.

To solve this problem, you can now create Vendor Bills or Purchase Orders 
for materials directly from the Act. Mat. Usage tab in QXpress. The Vendor 
Bill or Purchase Order gets posted into QuickBooks instantly, and the 
resulting materials get entered into the Act. Mat. Usage tab and Job Items 
tab.

To enter a Vendor Bill or Purchase Order:

1) Edit the occurrence of any service (i.e. do not edit the series of a recurring 
service).

2) Click on the Act. Mat. Usage tab.

3) Click Create Bill / P.O. for materials purchased in the field.

4) Select whether you want to create a Vendor Bill (i.e. you have already 
received the bill from the Vendor), or a Purchase Order (i.e. the Vendor will 
send you a bill at a later date and the bill will match a Purchase Order 
Number you provide).

5) Go through each of the fields and make the appropriate selection, if 
applicable.

Note: In the case of a Purchase Order, the Purchase Order Number will be assigned 
automatically once you post the Purchase Order to QuickBooks, as QuickBooks will 
provide you with the next sequential Purchase Order Number.

6) In the grid below, list all the Charge Descriptions for the items you are 
purchasing. Only Inventory and Non-Inventory Parts will be listed.
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7) Click Post Vendor Bill | Purchase Order to QuickBooks.

8) You will return to the Act. Mat. Usage tab with the quantities purchased 
entered automatically.

INVOICING

22. ‘Payment collected at time of service’ in Job Items tab

Versions: Gold, Platinum, Enterprise

Many service companies collect a payment from the customer at the time 
of service. In prior versions of QXpress, users would typically have to first 
post over invoices at the end of the day, and then go through all the 
payments received and post the payments into QuickBooks directly. For 
these types of service companies, this was cumbersome since it meant 
processing each service twice, once in QXpress for the invoice and once 
QuickBooks for the payment.

The new ‘Payment collected at time of service’ feature solves this problem 
by quickly and easily allowing you to enter the payment into QXpress when 
you are making any other edits to the service.

To enter a ‘Payment collected at time of service’:

1) Edit the occurrence of any service (i.e. do not edit the series of a recurring 
service).

2) Click on the Job Items tab.

3) In the lower left-hand corner, place a check in the Payment collected at 
time of service checkbox.

4) Enter the Amount, Pmt. Method and Deposit To values.

5) Finish any other edits to the service. When you are finish editing the 
service, click OK, or click on the Quick Invoice icon. The payment will get 
posted in QuickBooks once the invoice gets posted from QXpress to 
QuickBooks.

Note: For your convenience, QXpress will memorize the relationship between the Pmt. 
Method and Deposit To, so that the next payment you receive will have the Deposit To 
automatically filled in based on the Pmt. Method.
16 Feature List Alocet



23. Quick Invoice - create and post invoices directly from service

Versions: Gold, Platinum, Enterprise

For many companies that use ‘Invoice Upon Completion’ invoicing, the 
process to create a batch of invoices to send from QXpress to QuickBooks 
can be seen as cumbersome. This is especially the case when most 
services need to be edited at the end of the day.

For this reason, the Quick Invoice feature cuts out many unnecessary 
steps, and is more intuitive for those who just want to edit a service, put in 
times, materials, and payments received in the field, and post the service 
as an invoice to QuickBooks, all in one convenient step.

To use the Quick Invoice feature:

1) Edit the occurrence of any service (i.e. do not edit the series of a recurring 
service).

2) After making any final edits to the service in the Service screen, click on 
the Quick Invoice icon to the right of the Activities button.

3) Set any preferences in the Quick Invoice - Generate & Post to QuickBooks 
screen.

4) Click Generate & Post to QuickBooks.

5) The service will automatically be set to the status of ‘Done’, an invoice will 
be created, and then posted to QuickBooks. Also, if you entered a 
‘Payment collected at time of service’, the payment would get posted at 
this time as well.

TEMPLATE DESIGNER

24. Update email addresses from Email Templates screen

Versions: All

In prior versions of the Template Designer, there was a lot of confusion as 
to where the email addresses were coming from when emailing invoices, 
work orders or route lists from QXpress. When emailing invoices the email 
address comes from the customer’s email address in QuickBooks. When 
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emailing work orders and route lists, the email address comes from the 
Crew Leader’s email address in QuickBooks. But because this was not 
obvious, a lot of users found themselves always entering the email address 
every time they emailed templates.

To make this more convenient and intuitive, the Template Designer now 
prompts you if you want to update any email address entries, and will 
attempt to update QuickBooks directly with the updated email address.

To demonstrate this new feature:

1) Make sure you have a service scheduled in today’s calendar.

2) Take note of the crew this service has been assigned to.

3) Click Lists > Crews.

4) Choose the crew from the Crew Name dropdown list.

5) Ensure there is an employee chosen in the Crew Leader dropdown list.

6) Click OK.

7) In My Calendar, click Print > Print Work Orders / Route LIsts.

8) Choose your route list or work order template, and click OK.

9) In the Print Preview screen, click Send Email.

10) In the Select forms to email screen, click Edit Email.

11) Type in a new email address into the To field.

12) Click OK.

13) Ensuring QuickBooks is open, click Yes to any prompts that ask you to 
update the email address in QuickBooks.

CONTACT MANAGER

25. Contact Events appear in Day / Week view

Versions: Gold, Platinum, Enterprise
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Contact manager events can now appear as appointments in the Day and 
Week view of My Calendar.

The follow criteria have to be met for a Contact Manager Event to appear 
in My Calendar:

1) You must be in either Day or Week view.

2) The Contact Manager Event must be assigned to an Event Status that the 
‘Remind Me’ turned on.

3) The Contact Manager Event must be assigned to an employee.

4) The employee must be the same employee that is the Crew Leader of a 
crew visible in My Calendar.

Note: The Contact Manager Events will always appear as a 30 minute appointment.

26. New filter options on Contact Events list

Versions: Gold, Platinum, Enterprise

The Contact Manager now has more user-friendly filtering options that are 
similar to the filter options found in other QXpress screens. There are 6 
dropdown lists that represent each of the fields that you can quickly filter 
on. If you prefer, you still have the advanced filter options that were 
previously available in the Contact Manager.

27. New ‘Related Service’ field for Contact Events

Versions: Gold, Platinum, Enterprise

There is a new field available for Contact Manager Events, the Related 
Service field. Once you select a customer, the Related Service dropdown 
list will populate with all the services for that customer. The purpose is to 
track conversations and reminders that pertain to a specific service, such 
as follow ups on estimates given to customers.
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INTERFACE

28. Home & Learning Center

Versions: All

The Home & Learning Center is the new opening screen for QXpress 
users. It is meant to (i) give users an overview of tasks that need to be 
performed; and (ii) give new users an easier way to learn and understand 
QXpress.

To change the QXpress opening screen:

1) Click on the Home icon in the QXpress toolbar.

2) Under the Setup / Options frame, select whether you want your opening 
screen to be My Calendar as it was in prior versions of QXpress, or the 
Home & Learning Center as the new default of QXpress.

29. Customer Screen has a QuickBooks 2006 look

Versions: All

The Customer Screen has been slightly redesigned to have a more 
QuickBooks 2006/2007 look, and includes the new Edit Customer.

30. Multi-window

Versions: All

The Customer, Equipment, Charge Description List, Service, Service List, 
Invoice List and Contact Manager screens can now remain open while you 
work in other areas of the program. This, to many QXpress users, could be 
the single biggest new feature introduced by QX7.
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31. Show separately in Windows Task Bar option

Versions: All

As the Customer, Equipment, Charge Description List, Service, Service 
List, Invoice List and Contact Manager screens are opened, a new window 
is opened in the Windows Task Bar, allowing you to quickly go back and 
forth between the open screen and the My Calendar screen. Depending on 
your personal preferences, this may not be desirable, however, as you may 
not want may different screens showing in your Windows Task Bar.

To Show or Hide screens separately in the Windows Task Bar:

1) Click Edit > Preferences.

2) Click on the General tab.

3) In the Display frame, set your preference for the Show open screens 
separately in Windows Task Bar checkbox.

4) Click OK.

Note: Setting this preference will not affect screens already opened, i.e. if a screen is 
already open and this preference is change to be unchecked, the screens will not 
automatically hide until next time they are opened.

32. Invoice Types renamed

Versions: All

Type 2,3,5 and 6 invoicing types have been renamed to be more intuitive. 
The new names are “2 - Print: Before you go”, “3 - Print: Upon Completion”, 
“5 - Email: Before you go”, “6 - Email: Upon Completion”, respectively.

33. Ability to choose toolbar icons

Versions: All

You can now select which of the preset icons are visible in the QXpress 
toolbar.
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To show or hide toolbar icons:

1) Click Edit > Preferences.

2) Click on the General tab.

3) Under the Display frame, select which Toolbar Icons you want visible.

Note: There are no features for hiding the Home, Calendar and QX Sync icons, as well 
there are no features for adding your own additional icons.

OTHER FEATURES

34. Ability to hide Zone-based and Job Packages scheduling

Versions: Gold, Platinum, Enterprise

Zone-based scheduling is used mainly by companies that have services 
scheduled on no-specific date, a long time in the future. Only a few 
industries, however, actually use this feature, and therefore creates 
confusion for users who will never use it. New users will now find that 
unless they selected Lawn & Tree Spraying, or Irrigation in the Startup 
Interview, the Zone-based scheduling and Job Packages will be hidden.

To show / hide Zone-based scheduling and Job Packages:

1) Click Edit > Preferences.

2) Click on the Routing & Scheduling tab.

3) Place a check or remove the check from the Show Zone Based as a 
scheduling option? checkbox, depending on your preference.

4) Place a check or remove the check from the Show Job Packages as a 
scheduling option? checkbox, depending on your preference.

Note: You may need to close and reopen QXpress for some of these changes to take effect.

35. Spell check for job instructions and long charge description

Versions: All + requires Microsoft Word 2000 or later
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QX7 now has a spell checking feature for Job Instructions and Long 
Charge Descriptions.

To use the spell checking feature:

1) Edit any service.

2) Under the General tab, make sure you have some instructions in the 
Instructions for Crew field.

3) Click the “ABC” icon to the right of the Instructions for Crew. If there are no 
spelling mistakes or suggestions, no screen will appear. If there are 
spelling mistakes or suggestions, a Microsoft Word spell check window will 
appear to walk you through spelling corrections.

XORA compatibility

36. Integration with XORA on GPS-enabled Nextel phones

Versions: QXpress Gold, Platinum, Enterprise

XORA is a software application that is used on Nextel GPS-enabled mobile 
phones. The software allows your staff to track start and stop times, crew 
instructions, and set services to complete - while all the while collecting 
GPS locations.

By integrating with XORA, QXpress will send your list of services to your 
Nextel phone, where your staff can record their start and stop times. These 
times can then be downloaded back into QXpress.

The nice thing about this is your staff have a very simple interface and use 
the same Nextel phone they are using now.

It is not quite as powerful a mobile program as what QX Mobile will offer 
you, as it does not have your entire customer database, the ability to add 
jobs on the fly, the ability to track signatures, payments, material usage or 
print in the field, but it is the perfect option for someone looking for a simple 
way to eliminate paper work both for the field and office staff.
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To get more information on XORA:

1) Contact info@alocet.com and request more information regarding XORA.
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